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Preface 

This manual describes how to install and use the RingSys - WetCorr software. 
You should start by reading Appendix A. Installing RingSys and continue with 
chapter 3. Using RingSys - an exercise. The latter chapter describes the most 
frequently used commands. 

This manual covers software versions: 

RingSys v.5.4.b. 
Stat v.4.3. 
WetCorr v.4.1.a. 

950726 
921204 
941121 
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RingSys - W etCorr 
User's Manual 

1. Introduction 
RingSys is a data processing tool which offers a standardized method for storing 
and displaying WetCorr data. The system comprises a set of macros that run under 
Microsoft's spreadsheet Excel. The Windows environment secures a consistent 
and easy to use user interface. 

You must use Excel version 3.0 or 4.0. This software will not run properly under 
Excel version 5.0. 

2. Organizing the data 
The WetCorr data can be divided into 3 categories: 

1. Not scaled data downloaded from the System Controller. 
2. Scaled data in the database. 
3. Data extracted to work files from the database. 

The three categories are described below. 

2.1 Downloaded data from the System Controller 

You download data from the System Controller (SC) using one file per Sensor 
Adapter (SA). (To download data you must use a communication program such as 
Windows' Terminal. This procedure is not covered here.) You must use the 
following file naming conventions: 

ssssSAaa.SYM 

where ssss is the Site number. It must be 4 numerals. 
aa is the SA number, 01 - 16. It must be 2 numerals. 

If a site is registrated by the site number 0010 and you are using two SAs at the 
site the downloaded files must be called 00lOSA0l.SYM and 0010SA02.SYM 
respectively. You always download data to the \RINGDATA\SYM directory. The 
files in this directory are considered temporary. They are overwritten every time 
you download data. 

2.2 Scaled data in the database 

When you have downloaded your data files you must scale the data and include it 
in the site's database. The database files reside in subdirectories in the 
\RINGDATA\SYM directory. You decide how to organize your database files, 
e.g. you can use one subdirectory per site or you or one subdirectory per month or 
some other scheme. If you choose the latter you could call your database 
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directories \RINGDATA\SYM\9108, .... \9109, and so on. Before creating the 
database file for the first time you must create the database directory using the File 
Manager. 

When you add new data to the database files the new data is scaled automatically. 
0.1 is added to all Current values to avoid O (zero) in logarithmic plots. The 
Temperature values are left unchanged. 

2.3 Data extracted from the database files to work files 

The database files can become very large. Because it is not convenient to work 
with large files data is extracted from the database files before processed by 
RingSys, e.g. calculating TOW values and plotting TOW charts. Data is extracted 
from the database files on a one file per WetCorr sensor basis. That is an extracted 
file holds Current and Temperature data from one sensor only. The extracted files 
uses the following naming conventions: 

ssssAaac.CSV 

where ssss is the Site number, 0010 - 9999. 
aa is the SA number, 01 - 16. 
c is the Cell number 1 - 4. 

Data from cell number 2 on SA number 1 at site number 0010 is extracted to a file 
called 0010A012.CSV. RingSys creates the file names automatically. The 
extracted files are put in subdirectories in the \RINGDATA\CSV directory. The 
subdirectory names equal the database file subdirectory names. If a database file is 
located in the \RINGDATA\SYM\9108 directory then the extracted data files will 
end up in the \RINGDATA\CSV\9108 directory. 

Before extracting data for the first time you must create the extract directory using 
the File Manager. 

3. Using RingSys - an exercise 
This chapter will guide you through RingSys. We shall use data from two sensor 
adapter files which is included with the software. In order to complete the 
examples successfully you must use the selections specified in the text. 

The processing of WetCorr data can be divided into the following steps: 

1. Download data from the System Controller (SC). You create one file 
per Sensor Adapter (SA) including Current and Temperature 
roeasmemeots fram 4 seosars 

2. Build the downloaded data into the database on your PC. This process 
also scales the measurements. 

3. Extract data from the database to work files. You create one file 
including Current and Temperature measurements per sensor . 

4. Specify the WetCorr calculations. 
5. Start the calculations. 
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We shall look at examples of all steps except step 1. 

3.1 Starting RingSys 

You start RingSys from the Program Manager or from Excel. 

Starting RingSys from the Program Manager: 

* Choose the WetCorr program icon in the Excel group window. 

Starting RingSys from Excel: 

1. Choose open from the File menu. 
2. Go to the \RINGSYS directory and open the OPENRING.XLA macro. 

RingSys is added to the Excel menu bar. If you can not see it is probably because 
you are using short menus. Switch to long menus. When you choose RingSys 
from the Excel menu bar the RingSys menu bar appears. 

A shrinked document called WCSETUP.XLS appears in the lower left corner of 
your Excel window. The document holds setup information that RingSys uses. It 
must be open when using RingSys. 

3.2 Processing WetCorr data 

Processing data in RingSys includes scaling and storing your downloaded data 
files in database files, extracting data from the database, computing statistics and 
making charts. 

3.2.1 Building a database 

Assume that data have been downloaded from the SC into two files 
00lOSA0l.SYM and 0010SA02.SYM containing not scaled data from SA number 
1 and 2 and that the files have been copied into the \RINGDATA\SYM directory. 

The first thing to do is to scale and include the data in the database. 

To build a database: 

1. 

2. 

Choose Build Database from the File menu. The Build Database 
dialogue box appears. 
Locate the Specify Site group box. All available site numbers are 
listed in the Site No list box. Choose site number 0010. The site's 

3. 

4. 

adapters are listed m the Adapter list box. 
We want to build all of the site's adapter files into the database. Select 
UseAll in the Adapter list box. 
Locate the Series: yymmdd hhmm group box. Here you specify which 
part of the adapter files you want to add to the database. Let us add all 
data in the adapter files to the database. Select the Auto From and 
Auto To check boxes. 
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5. In the Directory text box you specify where the database resides. Enter 
9108. 

6. Choose command button OK to start the building of the database files. 

The data in our 2 adapter files which resides in the \RINGDAT A \SYM directory 
are now scaled and built into the database files which reside in the 
\RINGDATA\SYM\9108 directory. 

3.2.2 Extract Data 

Before calculating TOW and plotting charts we must extract the period of interest 
from the database to work files. 

To extract data: 

1. Choose Extract Data from the File menu. The Extract Data dialogue 
box appears. 

2. Locate the Specify Site group box. All available site numbers are 
listed in the Site No list box. Choose site number 0010. The site's 
variables are listed in the Variables list box. 

3. We want to extract data concerning all sensors. Select UseAll in the 
Variables list box. 

4. Locate the Series: yymmdd hhmm group box. Here you specify which 
part of the adapter files you want to extract from the database. Let us 
extract all data in the database. Select the Auto From and Auto To 
check boxes. 

5. In the Directory text box you specify where the database resides. Enter 
9108. 

6. Choose command button OK to start the building of the database files. 

The data concerning our adapters are now extracted from the databases which 
reside in the \RINGDATA\SYM\9108 directory to work files which reside in the 
\RINGDAT A \CSV\9108 directory. 

3.2.3 Open a work file 

After data extraction you have one work file for each sensor. In order to process 
the data you must open the work file. 

To open a work file: 

1. 
2. 
3 

Choose Open from the File menu. The Open dialogue box appears. 
Choose the 9108 subdirectory. 
Choose the QQ1 QaQ1 1 csv file and open the file 

The file is opened and put in a window covering the upper half of the screen. 

The block to the right in the work file window is called the Variable Definition 
Block (VDB). It specifies a range of format variables which RingSys uses when it 
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formats the work file and charts. The VDB is read from the site's File Definition 
Block (FDB) in the setup file WCSETUP.XLS each time the file is opened. 

3.2.4 Specify the WetCorr calculations 

Before running the calculations you must specify TOW thresholds and how to 
present the results. 

To specify the WetCorr calculations: 

1. Choose Specify WetCorr from the WetCorr menu. The Specify 
WetCorr Analysis dialogue box appears. 

2. We want to run statistics on the Current only and be able to plot both 
variables. Locate the Include group box. Select check boxes Plot for 
both variables and check box Statistics for the Current variable only. 

You can enable calculation of Temperature Statistics and Threshold detection by 
selecting the Temperature statistics check box. 

To specify the TOW thresholds: 

1. Choose the Thresholds command button in the Specify WetCorr 
Analysis dialogue box. The Specify thresholds dialogue box appears. 

2. Specify the TOW thresholds separated by commas. Do not include 
spaces! Enter the TOW thresholds 20 and 30. (You can enter a 
maximum of 4 Values). 

3. Choose the OK command button to return to the Specify WetCorr 
Analysis dialogue box. 

4. Choose the OK command button to exit the Specify WetCorr Analysis 
dialogue box. 

3.2.5 Starting the calculations 

You can either process one of the variables or you can process both Current and 
Temperature together. In the latter case TOW will be calculated for the Current 
only. 

To process all data concerning the Current variable: 

1. Activate the 0010a011.csv window. 
2. Select the Current column heading. 
3. Choose Start Calculations from the WetCorr menu. 

After some time a chart appears in the lower half of your screen. 

The statistics are output to the target worksheet. The target worksheet is hidden 
behind the workfile and chart windows. The values in the target worksheet always 
appear in the following order: 

Variable File name Avg. Min Max %>20 %>30 From date To date 
Current 0010A014 144.0 5 2506 30.61 2.55 91.08.25 91.08.26 
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3.2.6 Sending the chart to printer 

Once a chart is made you can send it to the printer. 

Sending the chart to printer: 

1. Activate the chart 
2. Choose Print Plot from the WetCorr menu. 

If the chart is printed over two pages you should try to experiment with the Chart 
Width and Chart Height values in the System Parameters dialogue box. You enter 
the dialogue box by choosing System Params from the File menu. 

3.2.7 Quitting RingSys 

When you have finished your session you can quit RingSys. 

Quitting RingSys: 

1. Choose Exit RingSys from the File menu. The End RingSys dialogue 
box appears. 

2. Choose command button OK. The RingSys menu bar is deleted and 
you are returned to the Excel menu bar. 

The setup document WCSETUP.XLS is not closed. You must close it manually. 

This completes the exercise. 

4. RingSys Ref ere nee 
This chapter describes all commands on all of RingSys' menus. 

4.1 The RingSys menu bar 

When you choose RingSys from the Excel menu bar the RingSys menu bar 
appears, see fig. 1. 

Eile Wet.Qorr Qptions 

Figure 1: The Ring Sys menu bar. 

4.2 The File menu 

The File roeou includes commaods for database processing, specification of 
system parameters, return to the Excel menu bar and quitting RingSys, see fig. 2. 
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Extract Data ... 

Open ... 
~ave 

S~stem Params ... 
Ex.Qel Menu 

E~it RingSys ... 

Figure 2: File menu. 

4.2.1 The Build Database command 

Building a database is the process of adding new data to an existing database or 
creating a new database. 

When you choose the Build Database command from the File menu the Build 
Database dialogue box appears, see fig. 3. 

Build Database 

Specify Site-----------, 

Site No Adapter 

Info: 

IWetCon 

Series: yymmdd hhmm 

Auto 
[8:]Erom: 
[8:J Io: 

1910825 1200 

1910826 0600 

Qirectory: 

19108 ~-------------~ 
I ........ 

"i 

Figure 3: The Build Database dialogue box. 

Look up To read about 

Chapter 5.1.2. How to fill in the SDB 0002 table. 

To build a database: 

1. 
2. 

3. 

4. 
5. 

Locate the Specify Site group box. 
Select the site number in the Site No list box. The site's adapters are 
listed in the Adapter list box. 
Select an adapter in the Adapter list box. If you want to add data from 
all adapters select UseAll. 
Locate the Series: yymmdd hhmm group box 
Specify the time period you want to add to the database. 
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You must enter the date and time using the following formats: 

yymmdd hhmm 

Do not include any separators. 

6. Specify the database directory in the Directory text box. Do not 
include any "\" before or after the name. The directory always resides 
in the \RINGDATA\SYM directory. 

7. Choose command button Start to start the building of the database 
files. 

The time period in the Series group box gives you the following options: 

Use this option 

Auto From 

To do this 

From (text box) 

Auto To 

To (text box) 

Add data from the start of the adapter file to the 
database. The date specified in the From text box is 
ignored. 
Add data from the date specified. You must clear the 
Auto From check box. 
Add data until the end of the adapter file to the 
database. The date specified in the To text box is 
ignored. 
Add data until the date specified. You must clear the 
Auto To check box. 

Look up 

Chapter 4.4.1. 

To read about 

How process multiple databases automatically. 

4.2.2 The Extract Data command 

The database files can become very large. Because it is not convenient to work 
with large files data is extracted from the database files before processed by 
RingSys, e.g. calculating TOW values and plotting TOW charts. Data is extracted 
from the database files on a one file per WetCorr sensor basis. That is an extracted 
file holds Current and Temperature data from one sensor only. 

When you choose the Extract Data command the Extract Data dialogue box 
appears. The dialogue box is identical to the Build Database dialogue box, see fig. 
3, except for the Adapter list box which is replaced by the Variables list box. The 
Current and Temperature variables for each cell are listed in the Variables list box. 
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To extract data from a site: 

1. Locate the Specify Site group box. 
2. Select the site number in the Site No list box. The site's Current and 

Temperature variables are listed in the Variables list box. 
3. Select a sensor in the Variables list box. The sensor variables are 

identified by an "A" in front of the adapter and sensor number. If you 
want to extract data from all sensors choose U seAll. 
When you choose a sensor both Current and Temperature variables for 
that sensor will be extracted together and put in a single sensor file. 
The variables in the Variables list box which begin with a "T" 
represent the Temperatures. Choosing them has no effect. 

4. Continue with specifying the time and date as described in chapter 
3.2.1. 

4.2.3 The Open command 

You use the Open command to open a work file. The work file includes Current 
and Temperature values from one sensor only. 

To open a work file: 

1. Choose the Open command from the File menu. The Open dialogue 
box appears. 

2. The directories are listed in the Directories list box. Change directory 
if necessary. 

3. The files are listed in the Files list box. Select the file you want. 
4. Choose command button Open to open the file. 

The work file is put in a window covering the upper half of the screen, see fig. 4. 

Site: 0010 001 0SA01 

Date Curr Temp. A013 T013 
91.08.25 102 8.8 VarName= Current Temp. 
91.08.25 111 9.3 lnfoNo= 2 2 
91.08.25 99 8.6 ChartTitle= Cell 3, Current Cell 3, temp. 
91.08.25 103 8.5 Ytexte Current [nA] Temp [0C] 
91.08.25 97 7.9 YFormat= Standard Standard 
91.08.25 99 7.8 Ymin= 0.1 -10 
91.08.25 96 7.4 Ymax= 1000 50 
91.08.25 91 6.9 Xtext= Date 
91.08.25 94 7.2 Xrnine 00:00 
91.08.25 93 6.8 Xmax= 23:59 

91.08.25 87 6.7 XlsDateFmt= åå.mm.dd 
91.08.25 92 7 
91.08.25 85 7.3 
91.08.25 88 6.7 

Figure 4: A work file loaded into RingSys. 
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The block to the right in the work file window is called the Variable Definition 
Block (VDB). It specifies a range of format variables used by RingSys to format 
the work file and charts made by RingSys. Each measurement variable (e.g. 
Current and Temperature) has it's own set of format variables specified in the 
Site's File Definition Block (FDB) in the setup file WCSETUP.XLS. The VDB is 
read from the setup file each time the work file is opened. 

4.2.4 The Save command 

The Save command writes your worksheet or chart to file. 

To save a worksheet or chart: 

* Choose Save from the File menu. 

Depending on the file type RingSys does the following: 

File to save is Action 

RingSys work file 
Setup file 

Any other file 

Saves the document without warning. 
Saves the document without warning. The document 
is saved to an Excel file as well as an ASCII file 
with extension .FMT. The FMT file is used by the 
database manipulating stand alone programs. 
Displays Excel's Save As dialogue box. 

4.2.5 The System Params command 

You use the System Params command to define and activate global settings used 
by RingSys. 

When you choose the System Params command the System Parameters dialogue 
box appears, see fig. 5. 

1811111 System Parameters 
-SetUp File 

1~.:i,'1 
File Name: lwcsETUP.XLS I■ 1111•111 
Qate Format: I åå.mrn.dd tt:mm I 

-Report -Chart 
-Print -Chart 0 Preferred 

1Zi erint 0To Dir: Width: EJ D ~arl v. ve-z 
I c:\ringdata I !:!eight: ~ 

0 Linear Fit □Exp. Fit - ~ 
- L...J~..,,u,~ 12SJ Line 

0 To Dirgctory: O.!.egend OM.arker 
I c:\ringdata I IZJ Cl_qse Report 

Figure 5: The System Parameters dialogue box. 
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The dialogue box is divided into 3 main group boxes: 

Group box: 

SetUp File 

Report 

Chart 

Function: 

Select setup file and setup file date and time formats. 
Activate changes made to SDB no. 0000. 
Specifies how the chart report is formatted before 
printing and how it is printed. 
Specifies how the chart is formatted. 

The SetUp File group box 

In the Set Up File group box you specify the setup file name. You can also activate 
changes made to SDB no. 0000. 

You may have several setup files, but only one can be active. You define the 
active setup file in the SetUp File group box. The default setup file is 
WCSETUP.XLS. 

To create a new setup file: 

1. Activate the setup document. 
2. Choose Save As from Excel's File menu and specify a new name in 

the Save Worksheet as text box. 
3. Choose command button OK to save the file. 
4. Return to the RingSys menu. 
5. Choose Save from the File menu to save the file as a RingSys 

document. 

To open a new setup file: 

1. Choose System Params from the File menu. The System Parameters 
dialogue box appears. 

2. Locate the SetUp File group box. 
3. Choose the Down Arrow in the File Name list box. 
4. Select a new setup file from the list. 
5. Choose command button OK. 
The new setup file is opened upon exit from the dialogue box. 

If you make changes to SDB no. 0000 in the current setup document those 
changes are not automatically activated. 

To activate changes made to SDB no. 0000: 

1. Locate the SetUp File group box. 
2. Choose Update. Changes made to SDB no. 0000 are activated. 
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Look up 

Chapter 5.1.1. 

To read about 

How to fill in SDB no. 0000. 

The Report group box 

In the Report group box you specify how the chart report is formatted and printed. 
The Report group box is divided into 3 sub-groups: 

Group box: 

Report Print 

Report Save 

Report Chart 

Function: 

Specifies where to print the chart report: No 
printout, to printer or to file. 
Specifies where to save the chart report or not to 
save it. 
Prepares the chart in the report before printout. 

The Report Print group box 

In the report Print group box you specify where to print the chart report. If you 
choose to print the report to file you can print it later by copying the file to the 
printer port. This is useful if you do not have a printer connected to your PC. 

Use this option: To do this: 

Print 

To Dir 

Print the chart report to printer or file. Clear the 
check box if do not want a printout of your report. 
Print the chart report to the directory specified in the 
To Dir text box. The directory must exist. The active 
printer must be a file called \ToDir\PRINTFIL.PRN. 
where ToDir is the directory specified in the To Dir 
text box. After the file is printed to PRINTFIL.PRN 
RingSys makes a copy of the file. The copy is named 
after the chart report worksheet with extension 
.PRN. That is \ToDir\STDRPn.PRN where n is an 
integer.Clear the check box if you want the file 
printed to your printer. 

The Report Save group box 

In the Report Save group box you specify where to save the chart report worksheet 
or not to save it. If you choose to save the report you can open it as a worksheet 
later. In order to format the x-axis date labels correctly you should also open the 
work file from which the chart was made. 
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Use this option: 

To Directory 

To do this: 

Save the chart report worksheet to the directory 
specified in the To Directory text box. The directory 
must exist. The report is saved to an XLS-file and 
named after the report worksheet. That is 
\ToDirectory\STDRPn.XLS where n is an integer 
and ToDirectory is the directory specified in the To 
Directory text box. Clear the check box if you do not 
want to save the report. 

The Report Chart group box 

In the Report Chart group box you specify the appearance of the chart in the chart 
report. You can specify the size of the chart in the printout, choose to print in 
colours or black and white, use legend and use solid or dotted data lines. 

In order for the chart to fit in on one page in the report printout you must specify a 
suitable chart width and height. If you change printer you may have to change 
these values. 

Use this option: To do this: 

Width 

Height 

Specify the width in columns that the chart will 
cover in the report worksheet. 
Specify the height in rows that the chart will cover in 
the report worksheet. 

Experiment with different width and height values until the chart covers a 
satisfactory part of your report printout. 

In order to make the chart printout as informative as possible you can control 
some chart attributes. If you have a colour printer or plotter you can print the chart 
in colours. If you can only make black and white printouts you can still distinguish 
different data lines by adding dot patterns to them. You can also add a legend box. 
These options only apply to the chart printout. They do not affect the way the chart 
appears on screen. 

Use this option: To do this: 

Colours Add different colours to data lines in the chart report 

Legend 

prmtout. You will usually use this option only when 
printing to a colour printer or plotter. 
Add a chart legend to the report printout. You will 
usually use this option only when Colours is selected 
too. 
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Look up 

The Chart group box 

To read about 

Additional ways of controlling chart formats. 

The Chart group box 

In the chart group box you can control the way the chart appears on screen as well 
as what kind of chart you want to make. The chart attributes are preserved in the 
printout. 

The chart attributes include data lines and/ or data marks. You can also choose to 
format the chart according to Excel's current preferred chart. 

Use this option: To do this: 

Line 

Marker 
Preferred 

Display the data series as lines. If you want to mark 
each data point only switch Line off and Marker on. 
You can use both. 
Mark each data point in the chart. 
Format a chart according to Excel's preferred chart 
type. Select this option if you want to make other 
chart s then scatter charts. The option is explained in 
more detail below. 

If you select the Preferred option your charts will be formatted according to 
Excel's preferred chart type. Before making charts you will have to tell Excel what 
your preferred chart is. 

To modify the default chart type: 

1. Make a WetCorr chart. 
2. Choose Excel Menu from the File menu. Excel's chart menu bar 

appears. 
3. Modify the chart using Excel's chart formatting commands. 
4. Choose Set Preferred from the Gallery menu. 
5. Choose Ring Sys Menu from the Ring Sys menu. The RingSys menu 

bar appears. 
6. Choose System Params from the File menu. 
7. Locate the Chart group box. 
8. Select the Preferred check box. All charts made by RingSys will be 

modified according to the preferred chart type. 

The preferred chart type you specified is active only until you exit Excel. Excel's 
preferred chart type is reset to default the next time you start Excel. 

The main use of the preferred chart function is to instruct RingSys to make bar, 
line or pie charts instead of scatter charts. Not all chart attributes can be changed. 
These are the most important limitations: 
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* 

* 
* 

* 

* 

* 

All formats specified in the File Definition Block (FDB) in the work file are 
applied to the chart if possible. 
Selections made in the Chart group are applied to the chart if possible. 
Selections made in the report Chart group box are applied to the printed 
chart if possible. 
If the preferred chart is not a scatter chart and both variables are plotted in 
one chart using two y-axes the second variable will be a line graph. 
If both variables are plotted in one chart using two Y-axes the text attached 
to the second y-axis will always be oriented downwards. 
The major and minor tick marks are always put outside the axes. The 
position of the x-axis tick labels are always at the bottom of the page. The 
position of the y-axis tick labels are always at the far left. 

The last group of options in the Chart group box allows you to make a scatter 
chart using two data series as x and y values respectively and include the least 
square fitted line for either linear or exponential fit. You can also choose to output 
statistical results to the chart report. 

Use this option: 

Varl v. Var2 

To do this: 

Linear Fit 

Create a scatter chart between two data series. The 
second variable (V ar2) in the work file is plotted 
along the x-axis while the first variable (V ar 1) is 
plotted along the y-axis. In order to use the option 
you must use both variables when making a chart. In 
order to get an intelligent chart you should turn Line 
off and Marker on in the Chart group box. 

Draw a straight line that best fits the data using the 
method of least squares. If Varl v. Var2 is not 
selected the analysis is applied to the date and 
selected variable using the dates as x-values. If Varl 
v. Var2 is selected the analysis is applied to the two 
variables using the second variable as x-values. Both 
data series have to be continues. In order to get an 
intelligent chart you should turn Line off and Marker 
on in the Chart group box. The straight line is always 
drawn. If you want the regression factors you must 
select Linear Fit in the Specify Statistics dialogue 
box and Statistics here in the Chart group box. 

Exp. ht Draw an exponential !me that best fits the data usmg 
the method of least squares. See Linear Fit for 
further explanation. 
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Statistics Output statistics to the chart document. The statistics 
output are those selected in the Specify Statistics 
dialogue box. You must select the Interval Size All 
check box in the Specify Statistics dialogue box. 

The formula used to compute the regression line is: 

Linear regression 
Exponential regression 

y=m*x+b 
y e b+ m v 

The factor r2 is the coefficient of determination. It compares estimated and actual 
y-values, and ranges in value from O to 1. If it is 1 there is a perfect correlation in 
the sample. 

4.2.6 The Excel Menu command 

To return to the Excel menu bar choose the Excel Menu command. The RingSys 
menu bar is deleted and the Excel menu bar appears. 

4.2. 7 The Exit Ring Sys command 

The Exit RingSys command closes the RingSys macros. The RingSys menu bar is 
deleted and you are returned to the Excel menu bar. When you choose the Exit 
RingSys command the End RingSys dialogue box appears, see fig. 6. 

End RingSys 

D ~ave settings 

Figure 6: The End RingSys dialogue box. 

To exit RingSys: 

1. Choose Exit RingSys from the File menu. The End RingSys dialogue 
box appears. 

2. Select the Save Settings check box if you want to save RingSys' 
dialogue box settings. You cannot save the settings in the dialogue 
boxes that belong to the WetCorr menu. If you do not want to save the 
settings clear the check box. 

The RingSys macros are closed The RingSys menu bar is deleted and yon are 
returned to the Excel menu bar. The setup document WCSETUP.XLS is not 
closed. You must close it manually. 

4.3 The WetCorr menu 

The WetCorr menu includes commands for specifying and runnmg WetCorr 
calculations, see fig. 7. 
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Start ~alculations 
J.:rint Pio! 

Figure 7: The WetCorr menu. 

4.3.1 The Specify WetCorr command 

Before running the calculations you must specify TOW thresholds and how to 
present the results. When you choose the Specify WetCorr command the Specify 
WetCorr Analysis dialogue box appears, see fig. 8. 

Specify WetCorr Analysis 
Include---------~ 

Current 
~ .S.tlltistics 

~elot 

Tempemture 
D St!!tistics 
~PIQt 

Figure 8: The Specify WetCorr Analysis dialogue box. 

The dialogue box is divided into 2 main groups: 

Group 

Include (group box) 
Thresholds 
(command button) 

Function 

Use this option 

Current Statistics 

Specifies what to include in the analysis. 

Specifies the threshold values used to calculate the 
TOW. 

The Include group box 

In the Include group box you specify what to include in the analysis. 

To do this 

Compute statistics including thresholds usmg the 

Current Plot 
Temperature Statistics 

Temperature Plot 

Current variable. 
Plot the Current variable. 
Compute statistics including thresholds usmg the 
Temperature variable. 
Plot the Temperature variable. 
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Remember that you can only specify one set of threshold values. If you choose to 
calculate thresholds using the Temperature variable these thresholds will be used. 

The Thresholds command button 

RingSys calculates the percentage of the total time that the values are above the 
specified thresholds. To specify the threshold values choose command button 
Thresholds. The Specify Thresholds dialogue box appears, see fig. 9. 

Specify Thresholds 

Ihresholds: 
20.30 lliflll 

Figure 9: The Specify Thresholds dialogue box. 

To specify the TOW threshold values: 

1. Choose the Thresholds command button in the Specify WetCorr 
Analysis dialogue box. The Specify Thresholds dialogue box appears. 

2. Enter your threshold values separated by commas in the Thresholds 
text box. Do not enter any spaces! You can enter up to 4 values. 

3. Choose OK to return to the Specify WetCorr Analysis dialogue box. 

To specify the standard WetCorr analysis setup: 

1. Choose the Specify WetCorr command from the WetCorr menu. The 
Specify WetCorr Analysis dialogue box appears. 

2. Locate the Include group box. 
3. Select the Current Statistics, Current Plot and Temperature Plot check 

boxes. 
4. Clear the Temperature Statistics check box. 
5. Choose command button Thresholds to specify the TOW threshold 

values. 

4.3.2 The Start Caculations command 

You use the Start Calculations command to manually start the statistical 
calculations and chart creation. 

To prepare for start calculations: 

1. Activate your work file. 
2. Select the variable(s) and time period you want to process. 
3. Choose the Start Calculations command. 
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You can choose to process one or both variables and you can choose to process 
the entire data series or only part of it. 

To process the entire data series of only one variable: 

1. Select only one cell in the data column you want to process. 
2. Choose the Start Calculations command. 

To process the entire data series of both variables together: 

1. Select one cell in the first data column and drag the mouse over to the 
next data column so that one cell in each column is selected. 

2. Choose the Start Calculations command. 

To process a continuos subset of the data series: 

1. Select one cell in the data column you want to process and drag the 
mouse until you have marked the subset of the data series. You do 
likewise when you want to process both variables together. 

2. Choose the Start Calculations command. 

After the calculations are done a chart appears in the lower half of your screen. 
The statistics are always output to the target worksheet. The results appear in the 
following order: 

Variable File name Avg. Min Max %>20 %>30 From date To date 
Current 0010A014 57.19 6 161 81.94 13.89 91.08.25 91.08.25 

If the To and From date columns contain "#####" it is because they are to narrow 
to display the dates. In the work file you will see some red spots above the 
variable Defintion Block. They indicate notes which contain the results of the 
thresholds calculations. Do not alter their contents. They are used when the chart 
is send to the printer. 

You are only allowed to process data that lies in column number 3 or 4 ( column 
number 2 is not visible). The Date column must not include any empty cells 
except after the end of the data series. RingSys searches the Date column for the 
first occurrence of an empty cell. This cell is defined to be the end of the data 
series. 

If you try to process data outside the legal area the Select Variable dialogue box 
appears, see fig. 10. 
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Select Variable 

Variable No. 
@1 

Oz 
Of!.oth 

1-1 

Series----------, 

Auto 
[X](Erom: ! I 91.04.16 20:40 
r8J Io: 191.04.17 08:oo 

Figure 10: The Select Variable dialogue box. 

In the Select Variable dialogue box you specify which variable(s) you want to use 
and which period you want to process. 

To specify manually what to process: 

1. Select a cell outside the legal processing area, e.g. the upper left cell in 
the work file. 

2. Choose the Start Calculations command. The Select Variable dialogue 
box appears. 

3. Locate the Variable No. group box. 
4. Choose which variable(s) to process. 
5. Locate the Series group box. 
6. Specify the time period you want to process. You must enter the date 

and time using Windows date and time formats. 
7. Choose command button OK. The processing starts. 

In the Variable No. group box you choose which variable(s) to process. 

Use this option To do this 

1. 
2. 
Both 

Process the Current variable. 
Process the Temperature variable. 
Process both variables together. 

In the Series group box you specify which part of the data series you want to 
process. 
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Use this option 

Auto From 

To do this 

From (text box) 

Auto To 

To (text box) 

Process data from the start of the work file. The date 
specified in the From text box is ignored. 
Process data from the date specified. You must clear 
the Auto From check box. 
Process data until the end of the work file. The date 
specified in the To text box is ignored. 
Process data until the date specified. You must clear 
the Auto To check box. 

Look up 

Chapter 4.3.1. 

To read about 

Which variable to calculate and plot. 

We will look at some examples of charts made by RingSys. The charts are made 
using the Variable Defintion Block (VDB) in fig. 11. 

A013 
VarName= Current 
lnfoNo= 2 
ChartTitle= Cell 3, Current 
Ytext= Current [nA] 
YFormat= Standard 
Ymin= 0.1 
Ymax= 1000 
Xtext= Date 
Xmin= 00:00 
xmax- 23:59 
Xscale= 
XlsDateFmt= åå.mm.dd 

T013 
Temp. 
2 
Cell 3, temp. 
Temp [0C] 
Standard 
-10 
50 

01:00 

Figure 11: This VDB is used in the example charts. 

We will only process the subset 91.08.25 00:00 - 91.08.25 11:50 of the work file. 

Creating a chart including only the Current variable 

Fig. 12. shows the chart when only the Current variable was processed. 
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Cell 3, Cui 

100 

···················curre 

81.9%>2( 

--ao.6%>3C 

0.1 

Da1 

Figure 12: The chart generated when only the Current variable was processed. 

Notice how the text labels, axes scaling and date format are taken from the VDB 
in the work file. The Xmin= format variable specifies that the X-axis minimum 
value should be at 00:00 of the first day in the processing period while The 
Xmax= format variable specifies that the X-axis maximum value should be at 
midnight of the last day in the processing period. 

Creating a chart including only the Temperature variable 

Fig. 13. shows the chart when only the Temperature variable was processed. 

Cell 3, 

5 

4 

3 

-l 

"' "' <O 
0 
;;. 

De 

Figure 13: The chart generated when only the Temperature variable was 
processed. 

Notice that you do not get any legend when the chart includes only one variable 
and no threshold lines. 
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Creating a chart including both variables using individual Y-axis 

Fig. 14. shows the chart when only the Current variable was processed. 

Cell 3. CL 

100 

0.1 

50 

40 

10 

0 

-10 

···················currE 
30 _f 81.9%>21 
20--:' 

3 -- 80.6%>31 

Terrr 

;'J 
<O 
CO! 
er 

Da· 

Figure 14: A chart including both variables using individual Y-axis. 

The chart title equals the value of the ChartTitle= format variable of the Current in 
the VDB in the work file. You get two individually scaled and labelled Y-axes if 
at least one of the format variables Ytext=, Ymin= or Ymax= of the Current and 
Temperature do not equal each other respectively. 

4.3.3 The Print Plot command 

Once the chart is made you can create a report and send it to the printer by 
choosing the Print Plot command. You can only print the last chart you made from 
a work file. If you have made two TOW-charts and decide to print the former the 
report will include the TOW values of the latter chart! Also the work file which 
the chart was made from must be open. Fig. 15. shows a printed report of the chart 
in fig. 12. 
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Site: 0010 0010SA01. WetCorr, SA 1 

Date 
From: 91.08.25 00:00 
To: 91.08.25 11 :50 
Printed:95.07.2610:12 

Rin S s ILAB NILU 

Threshold % TOW 
20nA 81.9 
30 nA 80.6 

Cell 3, Currer 

1000 

100 
<(' 
..s .., 

10 i:: 
Q) ,._ ,._ 
:::, 
u 

0.1 
Il') 

"I 
00 q 
,- 
OJ 

co 
N co q 
,- 
OJ 

Date 

Figure 15: Report printout of the chart in figure 12. 

Look up 

Chapter 4.2.5. 

To read about 

Other ways of formatting and printing the report. 

You must print the target worksheet using Print from Excel's File menu. 

4.4 The Options menu 

The Options menu, see fig. 16, includes the Auto Processing command which 
gives you the possibility of automating some of the processing task and the About 
command which displays system information. 

Figure 16: The Options menu. 
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4.4.1 The Auto Processing command 

You use the Auto Processing command to process your data automatically. 

The Auto Processing command uses the information in System Defintion Blocks 
(SDB) no. 0001 and 0002 in the setup document to process the data files. 

When you choose the Auto Processing command the Auto Processing dialogue 
box appears, see fig. 17. 

Specify Auto Processing 

Include: 
D !;!_uild Database 
D .Extract Data 
D WetCorr Calculations 

~Options--~ 
@csy 
O~LS 

O.Beverse 
D~tatus 

lllllllllll 

Figure 17: The Specify Auto Processing dialogue box. 

The number of options in the Include list in the dialogue box will vary depending 
on which add in macros you are using. Fig. 17 shows the standard options. The 
Include list is always executed from top to bottom. You can combine several tasks 
such as extracting data and making charts in one action. 

Use this option 

Build Database 
Extract Data 

To do this 

WetCorr Calculations 

Build database files according to SDB no. 0002. 
Extract data from database files to CSV-files 
according to SDB no. 0001. 
Compute WetCorr statistics and charts according to 
SDB no. 0001. Remember to turn on the Print check 
box in the Report Print group box in the System 
Parameters dialogue box in order to make hard 
copies of the charts. 

The Build Database and Extract Data options all work on database files while the 
WetCorr Calculations option process extracted work files only. 

The options in the Options group box allow you to specify what kind of work files 
you want to process, the order of processing and whether you want a status report 
or not. The options are used by the Charts and Statistics options only. 
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Use this option To do this 

csv 
XLS 

Reverse 

Status 

Process CSV work files. 
Process Excel work files. The Excel work files must 
be formatted as a RingSys work file. 
To process SDB no. 0001 from bottom to top. Use 
this option to reverse the order of your printouts. 
To print a status report. The status report includes 
information about missing data or files. 

The Status option is useful for detecting missing data or files. Fig. 18. shows a 
status report. 

Status report printed: 93.07.26 15:07 

No data in: c:\ringdata\csv\0011ozon.csv, Utvika, Ozon, 91.05.01 00:00 - 91.05.02 00:00 
Directory not found: c:\ringdata\csv\93oct, 001 0SA01, 0011, A011 

Figure 18: A status report showing some error conditions. 

To start automated processing: 

1. Fill in SDB no. 0001 and 0002 depending on what kind of functions 
you want to run. 

2. Save the setup document using Save from the File menu. 
3. Choose Automated Processing from the Options menu. The 

Automated Processing dialogue box appears, see fig. 17. 
4. Select the functions you want to run in the Include list. 
5. Specify file type etc. in the Options group box as necessary. 
6. Choose Start. The automated processing begins. 

Once the automated processing is started it must run to it's end. But if you have 
chosen Charts and you are making hard copies the Cancel dialogue box appears 
every time a chart is sent to the printer. If you Cancel the printout you also abort 
the automated processing. 

To abort automated printout of charts: 

1. Wait for the Cancel dialogue box to appear. 
2. Choose Cancel. The automated processing is aborted. 

You can also abort the pi:ocessing by hitting <Esc> at any time. Doing so displays 
Excel's Macro Interrupt dialogue box. This does not apply to the The Build 
Database and Extract Data functions. This is an illegal way of aborting the 
process. RingSys is left in an unstable state and strange things might happen later. 
You should not choose Save Settings upon exiting RingSys if you have 
interrupted the macro at any time by hitting <Esc>. 
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To abort any automated processing: 

1. Hit <Esc>. The Macro Interrupt dialogue box appears. 
2. Choose Halt. The automated processing is aborted. 
3. Choose Close from the File menu to close all open documents. 

Look up To read about 

Chapter 5 .1.2. 
Chapter 5 .1.3. 

How to specify SDB no. 0001. 
How to specify SDB no. 0002. 

4.4.2 The About command 

You use the About command to display information about the RingSys macro's 
version number and user support. 

When you choose the About command the RingSys About dialogue box appears, 
see fig. 19. 

0 
Ring Sys v.5.4.b, 950726. Ring Sys is developed at the Norwegian 
Institute For Air Research (NILU) by Leif Marsteen. Tel. 47 63 89 80 
00. Post: NILU, P.O. Box 100, N-2007 Kjeller. This program is 
licenced to WetCorr. 

Figure 19: The RingSys About dialogue box. 

5. The setup file 
The setup file is an XLS-document. It must be open during a RingSys session. The 
active setup file is defined and opened in the System Parameters dialogue box. If 
you make changes to the setup file you must always save it using the Save 
command from Ring Sys' File menu before proceeding. 

The information in the setup file is organized in Site Definition Blocks (DB). 
There are two main types of DBs, the System Definition Blocks (SDB) and the 
File Defintion Blocks (FDB). 

Site Definition Block Holds 

System Definition Block System information and tables for automated 
processing. Occupies site numbers 0000 - 0009. 
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File Defintion Block Description of the database file formats and 
information about how the work file and charts 
should be formatted. Occupies site numbers 0000 - 
0009. 

Each DB is identified by a unit site number. The site number must consist of 4 
numerals. Legal site numbers are 0000 - 9999. The 0000 - 0009 site numbers are 
reserved for SDB use. You can only use site numbers 0010 - 9999 for FDBs. 

The WCSETUP.XLS setup file assumes that you have installed RingSys on the C 
drive. A File Definition Block called 0010 is included in the setup file. It is ready 
for use. You can change the site number and database file names if necessary. 

5.1 The System Definition Blocks (SDB) 

The System Definition Blocks (SDB) hold system information and tables for 
automated processing. The SDBs are identified by a site number less then 0010. 
That is site numbers 0000 - 0009 are reserved for SDB use. 

5.1.1 System Defintion Block 0000 

System settings are defined in SDB 0000. Fig. 20. shows SDB 0000. 

[Site]No= 0000 
SiteNumbers= 001 o ' 
DatabaseDir= C:\RINGDATA\SYM 
Extractoir= C:\RINGDATA\CSV 
[End] 

Figure 20: System Defintion Block 0000. 

The following format variables are of interest: 

Format variable Value(s) 

DatabaseDir= 

ExtractDir= 

The standard database file directory including the 
drive specifier. RingSys assumes that the unscaled 
database files are stored in this directory. The 
database files are assumed to be stored in 
subdirectories that reside in this directory. 
The standard extracted file directory including the 
drive specifier. RingSys will extract data from the 
database files to subdirectories that reside in this 
directory. 

Look up 

Chapter 4.2.5. 

To read about 

Other system settings. 
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5.1.2 System Definition Block 0001 

SDB no. 0001 is a table that specifies the following automated procedures: 

* 
* 

Extracting data from the database files to work files. 
Work file processing such as computing statistics and making charts. 

Fig. 21 shows an example of SDB no. 0001. 

[Site]No=0O0l 
SiteNumber Sensor UseCurr UseTemp FromDate 
0010 A0ll Y N 91.08.25 13:00 
0010 B Y N A 
[End] 

ToDate 
91.08.25 21:00 

A 

Period 
A 
A 

Directory 
9018 
9108 

Figure 21: System Definition Block no. 0001. 

SDB no. 0001 uses the following format variables: 

Format variable Value(s) 

[Site ]N o=000 1 

[End] 

The site identifier. Start of SDB. The site number 
must be 0001. 
EndofSDB. 

The table between the start and end markers specifies which variables should be 
processed and in which periods. 

Column Value 

Site Number 

Sensor 

Use Current 

The number of the site you want to process. It must 
be 4 numerals. If you enter';' in front of the number 
Ring Sys ignores the row. In order for Excel to 
display leading zeros (e.g. 0091) the column's 
number format must be 0000. 
The file identity of the variable you want to process 
as specified by the Fileldentity= format variable in 
the site's File Definition Block in the setup. Enter * 
(asterisk) to process all variables belonging to the 
site. Even if you want to process the second variable 
in the work file you must enter the file identity of the 
first variable. 
Enter 'Y' if you want to process the Current. Enter 'N' 
if you do not want to process it. If you enter 'B' 

Use Temp. 

(Both) and choose automated printout of charts both 
variables will be plotted together in one chart. But 
only the statistics of the Current will be computed. 
Enter 'Y' if you want to process the Temperature. 
Enter 'N' if you do not want to process it. 
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From Date 

To Date 

The date from which you want the processing to 
start. Enter 'A' (Auto) if you want to process data 
from the start of the file. 
The date at which you want the processing to stop. 
Data at To Date is processed if found. Enter 'A' 
(Auto) if you want to process data until the end of 
the file. 

You must enter the From and To Dates using Windows' date format notation. 

Period You can process data between From Date and To 
Date in intervals. Enter 'A' (Auto) to process the 
whole period as one interval. The column is not used 
by the database processing commands. Legal interval 
size codes are: 

nY n Years 
nM n Months 
nD nDays 
nH n Hours 
nN n rniNutes 
nS n Seconds 

Directory 

where n is an integer. There is no spaces between the 
integer and the letter. The first period starts at From 
Date and ends just before From Date + Period. The 
second Period starts at From Date + Period and so 
on. 
The name of the database and work file 
subdirectories. The directories must be located in the 
standard database and extracted work file directories 
respectively. Do not include any '\' (backslash) 
before or after the directory name. You can specify a 
subdirectory such as 9108\NORTH. If you do not 
specify any directory it is assumed that the standard 
database and work file directories will be used. 

5.1.3 System Defintion Block 0002 

SDB no. 0002 is a table that specifies the following automated procedures: 

* Building database files. 

Fig. 22. shows an example of SDB no. 0002. 
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[Site]No=0002 
SiteNumber Adapter No. 
0010 * 
0010 1 
[End] 

Use Adapter 
y 
N 

FromDate 
A 

91.08.25 00:00 

ToDate 
A 

91.08.25 12:00 

Directory 
9108 
9108 

Figure 22: System Definition Block no. 0002. 

SDB no. 0002 uses the following format variables: 

Format variable Value(s) 

[Site ]No=0002 

[End] 

The site identifier. Start of SDB. The site number 
must be 0002. 
End of SDB. 

The table between the start and end markers specifies which database files should 
be processed and in which periods. 

Column Value 

Site Number 

Adapter No. 

Use Adapter 

From Date 

To Date 

The number of the site you want to process. It must 
be 4 numerals. If you enter ';' in front of the number 
RingSys ignores the row. In order for Excel to 
display leading zeros (e.g. 0091) the column's 
number format must be 0000. 
The number of the adapter you want to process, 1 - 
4. You find the number by counting file names after 
the FileName= format variable in the site's FDB. Do 
not count the text 'UseAll' if it appears. Enter * 
(asterisk) if you want to process all adapters used at 
the site. 
Enter 'Y' if you want to process the specified adapter. 
Enter 'N' if you do not want to process it. 
The date from which you want the processing to 
start. Enter A (Auto) if you want to process data 
from the start of the database file. 
The date at which you want the processing to stop. 
Enter 'A' (Auto) if you want to process data until the 
end of the database file. 

You must enter the From and To Dates using Windows' date format notation. 

Directory= The name of the database file subdirectory. It is 
assumed that the directory is located in the standard 
database file directory. Do not include any '\' before 
or after the directory name. You can specify a 
subdirectory, e.g. 9108\NORTH. You must specify a 
subdirectory. 
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5.2 The File Definition Block 

Every site must be defined in a FDB in the setup file in order for RingSys to be 
able to process it. The declaration includes a unit site number which identifies the 
site and the site's FDB. Fig. 23. shows the FDB for site 0010. 

[Site]No=0010 
FileName= UseAII 
Info= WetCorr 

0010SA01 0010SA02 0010SA03 0010SA04 
WetCorr, SA 1 WetCorr, SA 2 WetCorr, SA 3 WetCorr, SA 4 

Fileldentity1 = Date UseAII A011 T011 A012 T012 A013 T013 A014 T014 A021 
/Excel Data/ 
VarName= X X Curr Tmp. Curr Tmp. Curr Tmp. Curr Tmp. Curr 
ChartTitle= X X Cur1 Tmp1 Cur2 Tmp2 Cur3 Tmp3 Cur4 Tmp4 Curs 
Ytexte X X [nA] [OC] [nA] t-c [nA] [OC] [nA] [OC] [nA] 
Yrnine X X A ·10 A ·10 A ·10 A ·10 A 
Ymax= X X 1000 50 1000 50 1000 50 1000 50 1000 
Xtext= Date 
Xrnine 00:00 
Xrnax» 23:59 
Xscale« 1 01:00 
XlsDateFmt= åå.mm.dd 
[End] 

Figure 23: A File Definition Block. 

Some of the lines in the FDB are hidden because they are rarely changed. 

You should change the [Site]No= and FileName= entries to reflect your site 
number and database file names respectively. You should also change the 
XlsDateFmt= variable to reflect your (Windows) language. If the language is 
English change the entry to yy.mm.dd hh:mm. 

Like the SDB the FDB has the standard format variables: 

Format variable Value(s) 

[Site ]N o=nnnn 

Info= 

[End] 

The SDB identifier. nnnn is a site number consisting 
of 4 numerals. Legal values are 0010 - 9999. 
The contents of the information cells belong to the 
cell above them respectively. That is each adapter 
has its own information cell. The information is 
output to the adapter's charts. 
The end marker of the FDB. 

The FDB in fig. 23. describes a typical WetCorr setup. The site includes 4 
adapters called 001 0SA01, 001 0SA02, 001 0SAQ3 and 001 0SA04 respectively 
Because of lack of space only the first 5 sensors are shown in the figure. 

The following format variables describe the database file format: 
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Format variable Value(s) 

FileName= 

Fileldentity= 

The first value must equal UseAll. This text appears 
in the Build Database dialogue box. In the following 
cells enter the namers) of the database/ adapter 
file(s), e.g. OOlOSAOl, 0010SA02 etc. 
The values identify the cells. The values must equal: 

Date UseAII A011 T011 A012 T012 A013 T013 A014 T014 A021 ... 

The values continue until the current and 
temperature on the last cell, A044 T044. 

The format variables below the ÆxcelData/ label are used to format the work file 
and charts: 

Format variable Value(s) 

VarName= 

ChartTitle= 

Ytext= 

Ymin= 

Ymax= 

Xtext= 

Xmin= 

Xmax= 

The text appears on top of the data column in the 
work file and in the chart legend box. You may 
format the text. 
The text appears as chart title text. You may format 
the text. 
The text appears along the Y-axis. You may format 
the text. 
The Y-axis minimum value. Enter A (Auto) if you 
want Excel to auto scale the minimum value. 
The Y-axis maximum value. Enter A (Auto) if you 
want Excel to auto scale the maximum value. 
The text appears along the X-axis. You may format 
the text. 
The X-axis start date. Enter A (Auto) if you want 
Excel to auto scale the start date. 
The X-axis start date. Enter A (Auto) if you want 
Excel to auto scale the start date. 

The start end date must be entered using Windows' date format notation and the 
column's number format must equal the format specified in the System 
Parameters dialogue box. 

If you do not specify a year and day but only the hour, e.g. 00.01.00 00:00 or 
00:00 in Ymin= the start date is set to the specified hour of the first date in the 
data series. If you do not specify a year and day but only the hour, e.g. 00.01.00 
23:59 or 23:59 in Ymax= the end date is set to the specified hour of the last date 
in the data series. 00:00 and 23:59 respectively is the default setting. 
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Xscale= 

XlsDateFmt= 

The distance between X-axis tick labels (in days) 
and tick marks (in hours) respectively. Enter A 
(Auto) if you want Excel to auto scale the distances. 
The hours are specified as hh:mm, e.g. 12:00 for tick 
marks every 12 hours. 
The date and time format used to format the date 
column in the work file and the X-axis tick labels in 
the chart. The format must be entered using Excel's 
date format number notation. e.g. yy.mm.dd if you 
only want to display the dates or yy.mm.dd hh:mm if 
you want to display both date and time. 
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Appendix A 

Installing RingSys 
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Installing RingSys 
In order to run RingSys you must satisfy the following minimum requirements: A 
80386 SX PC including 4Mbytes of RAM, a mouse, VGA monitor, printer, DOS 
3.3 or later, MS Windows 3.0 or later and MS Excel 3.0. or 4.0. You will run in to 
problems when using MS Excel 5.0. 

It is assumed that you will install RingSys on drive C:. If you want to use another 
drive you must contact Leif Marsteen at NILU for a customised installation. 

Adding RingSys to your DOS path 
You must add the path of the RingSys program files directory to your DOS path. 

Editing AUTOEXEC.BAT: 

1. Start Windows. 
2. Open the Accessories document icon in the Program Manager and 

choose the Notepad program item icon. 
3. Choose Open from the File menu. In the File Name text box enter: 

c:\autoexec.bat 
and choose command button OK. 

4. Locate the PATH= ... entry. Add the following text to your existing 
path command: 

;C:\RINGSYS 
5. Choose Save from the File menu to save your changes and exit 

Notepad. 
6. Reboot the computer. 

Installing RingSys: 

1. Start Windows. 
2. Choose Run from the File menu in the Program Manager. 
3. In the Command Line text box enter: 

A:INSTALL.BAT A: C: 
where A: is your source diskette drive and C: is the target drive for 
your installation. 

4. Choose OK. RingSys will be installed. 

Adding RingSys to the Excel group window 
If you do not want to be able to start RingSys from the Program Manager you can 
skip this chapter. You can always start RingSys from Excel. 
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Adding RingSys to the Excel group window in the Program Manager: 

1. Activate the Excel group window. 
2. Choose New from the File menu. The New Program Object dialogue 

box appears. 
3. Choose Program Item. 
4. Choose command button OK. The Program Item Properties dialogue 

box appears. 
5. In the Description text box enter: 

RingSys 
6. In the Command Line textbox enter: 

c:\excel\excel.exe c:\ringsys\openring.xla 
7. Choose command button OK. RingSys is added to the Excel group 

window. 

Checking Windows' International settings 
In order for RingSys to processes our data files correctly we need to adjust 
Windows' date and time formats, the number separator and the list separator. 

Setting Window's date and time formats: 

1. Open the Main document icon in the Program Manager and choose the 
Control Panel program icon. 

2. Choose the International program icon in the Control Panel document 
window. 

3. Locate the Date Format and Time Format group boxes. We 
recommend that you use the following date and time formats 
respectively: 

yy.mm.dd hh:mm 
4. Change the formats if necessary. 

The International dialogue box also displays Window's number separators which 
we must inspect. 

Setting Window's number separators: 

1. Locate the Number Format group box. The 1000 separator must equal 
"," (a comma) while the decimal separator must equal"." (a dot). 

2. Change the formats if necessary. 

Th@ Int@rnational dialogu@ box. also displays Window's list separator which w@ 
must inspect. 

Setting Window's list separator: 

* Locate the List Separator text box. Change the list separator to "," (a 
single comma). Choose OK. 
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Setting the date and time forma ts in RingSys 
The installation is now almost done. We only need to register Window's date and 
time formats in RingSys. Choose program icon RingSys in the Excel document 
window or start RinsgSys from Excel by opening the 
C:\RINGSYS\OPENRING.XLA macro . RingSys should be loaded successfully. 
The RingSys menu is added to your Excel menu bar. 

Setting the date and time formats for charts and work Jiles 

A shrinked window called WCSETUP.XLS appears in the lower left comer of 
your Excel window. This is the setup file. Here all sites are specified individually. 

Setting the date and time formats used to format charts and work files: 

1. Maximize the WCSETUP.XLS window. 
2. Select the entire first column. 
3. Choose Find from the Formula menu. The Find dialogue box appears. 

In the Find What text box enter: 
XlsDateFmt= 

and choose OK. Hopefully Excel found the entry. 
4. Change the value of the entry to reflect your Windows' language, e.g. 

åå.mm.dd tt:mm if it is Norwegian or yy.mm.dd hh:mm if it is 
English. 

5. Repeat the procedure for all occurrences of the entry. 

Setting the system date and time format 

The RingSys system date and time format is used to format the date and time in 
System Definition Blocks 0001 and 0002 in the setup file. It is specified in the 
System Parameters dialogue box. 

Setting the system date and time formats: 

1. Choose RingSys from Excel's menu bar. The RingSys menu bar 
appears. 

2. Choose System Params from the File menu. The System Parameters 
dialogue box appears. 

3. Locate the Setup File group box. 
4. Change the value of the Date Format to reflect your Windows' 

language, e.g. åå.mm.dd tt:mm if it is Norwegian or yy.mm.dd hh:mm 
if it is English. 

5. Choose command button Update to register the changes in RingSys. 
6. Choose OK. 

This completes the installation. If you want to use another site number then 0010 
which is default you should read chapter 3.2. The File Definition Block. However 
you should change the number only after having done the exercise in chapter 1. 
Using RingSys - an exercise. 
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